Umstellungen PHP Versionen

Wir möchten Sie über die anstehende Aktualisierung der PHP-Software für Ihr Webhosting informieren. PHP ist die Programmiersprache, welche für dynamische Webseiten verwendet wird. Weil die meisten Web-Applikationen auf eine PHP-Version angewiesen sind, müssen Sie vorgängig die Kompatibilität prüfen.

 

 

Bin ich betroffen?

 

Diese Informationen sind für Sie wichtig, wenn Sie eine Webseite mit PHP verwenden. Dies ist beispielsweise der Fall, wenn Sie ein CMS wie Wordpress, Joomla, TYPO3 oder andere verwenden. Stellen Sie daher unbedingt sicher, dass Sie eine aktuelle Version der Applikation installiert haben oder aktualisieren Sie Ihre Installation und allfällige Plugins.

 

Für Webseiten, welche mit unserem Baukasten "Sites" oder unserem Webshop "ePages" erstellt wurden, muss nichts unternommen werden. Diese Applikationen werden von uns aktualisiert.

 

 

PHP 7.2 jetzt verfügbar

 

Die aktuellste Version PHP 7.2 ist auf unseren Systemen bereits verfügbar. Bitte testen Sie jetzt schon, ob Ihre Webseiten mit dieser Version funktionieren. Sie können die PHP Version für Ihre Webseite im Control Panel konfigurieren.

 

 

Wenn Ihre Webseite danach weiterhin problemlos funktioniert, sind keine weiteren Massnahmen mehr notwendig. Falls Sie Fehlermeldungen erhalten, sollten Sie überprüfen, ob Ihre Applikation sowie die Plugins und Themes auf dem aktuellsten Stand sind. Klären Sie allenfalls beim Hersteller Ihrer Applikation ab, ob diese PHP 7.2 kompatibel ist oder ab wann dies geplant ist.

 

Sollten Sie Ihre Webseite selber programmiert haben, beachten Sie bitte die Dokumentation von PHP:

 

 

PHP 7.2 voraussichtlich ab Spätsommer Standard

 

Voraussichtlich im Spätsommer 2018 werden wir alle Webseiten, die bis dahin PHP 5.6 oder PHP 7.0 verwendet haben, auf PHP 7.2 umstellen. Das genaue Datum der Umstellung der einzelnen Server werden wir an dieser Stelle laufend erläutern.

 

Bitte stellen Sie sicher, dass Ihre Applikationen bis dahin bereits mit PHP 7.2 kompatibel sind. Sollte dies nicht der Fall sein, können Sie im Control Panel noch auf eine ältere Version zurückgreifen.

 

Sollten Sie im Cronjobs mit PHP einsetzen, überprüfen Sie bitte ebenfalls, ob diese eine fix definierte PHP Version verwenden und passen Sie diese gegebenenfalls an. Die Versionen für "php" und "php-head" werden ab dann ebenfalls auf PHP 7.2 verweisen. Die Pfade zu den verschiedenen PHP Versionen finden Sie unter der Seite Pfade, Verzeichnisse, System.

 

 

End of life PHP 5.6 und PHP 7.0

 

Die Entwickler von PHP haben angekündigt, wann die Versionen 5.6 und 7.0 nicht mehr unterstützt werden. Ab dann wird es keine Updates mehr für diese Versionen geben. Aus Sicherheitsgründen deaktivieren wir diese Versionen zu dem Zeitpunkt, da neu entdeckte Sicherheitslücken in diesen Versionen nicht mehr behoben werden. PHP 5.6 wird noch bis Ende Dezember 2018 verfügbar sein, PHP 7.0 bis Anfang Dezember 2018.

 

Die Roadmap von PHP finden Sie unter http://php.net/supported-versions.php

 

Bei weiteren Fragen steht Ihnen unser Support gerne zur Verfügung.

 

Leistungsausbau Webhosting

Informationen zur PHP Umstellung

 

Konnten Sie finden, was Sie suchen?

Unsere Support-Profis helfen Ihnen gerne persönlich weiter!

 

© 2001 - Hostpoint AG