End of Life PHP 5.6 and 7.0

The developers of PHP (The PHP Group) did end the support for the deprecated versions of PHP 5.6 and 7.0 at the end of 2018.

We will therefore deactivate these versions from the second week of January 2020.

The newer versions (PHP 7.2 and 7.3) will be further developed and supported.

Selecting the PHP version

You can select the PHP version for a website or individual directory.

The options are found here:

  • "Websites" -> "Web settings" for the respective website

or

  • "Explorer/Web settings" -> "Web Settings for this Directory" for the desired directory.

The benefits of PHP 7.2

We do explicitly reccommend the use of PHP 7.2. Alternatively you could switch to PHP 7.1, but this version will most likely only be supported until the end of 2019. Besides all the security benefits, PHP 7.2 is also the better choice in terms of performance. Especially with Content Management Systems like Wordpress, which gains a noticeable increase in performance.

The change to PHP7.2

As annouced earlier this year, we have switched the default-PHP-version to PHP 7.2 during september 2018. If you did not manually set a specific PHP-version before or after this change, all your applications will use PHP 7.2 and the change is completed. The current PHP-version is visible (and changeable) in the Web-Settings of your website. If you use one of the older versions, you should make sure that your applications and websites work with the current version (7.2) as soon as possible.

Generally speaking, all current CMS and webapplications should be compatible with PHP 7.2. In most cases, incompatibility is due to outdated versions of plugins or components and can be resolved easily by updating those to the newest version. Should a problem occur when using PHP 7.2, you will be able to switch between all available versions until march 2019, so your applications will work reliably.

If you have created applications manually, the official migration guides from PHP might be helpful:

Should you run into technical issues which prevent you from updating, please contact our support team. We will gladly assist you.

Regular updates are easy on the nerves

Keeping up with the technolgy helps. If you update your applications and websites regularly you will not only have the upper hand in terms of security, but it also reduces the general risk of updates greatly because the distances between the versions are not too long. The changes between concurrent versions (i.e. from 2.3 to 2.4 or from 1.8.2 to 1.8.3) are well monitored and tested and should work without problems. Also most themes and plugins should be able to handle small version-changes without any issues.

The risk increases greatly if you fall behind and the pending updates accumulate. Once small and fixable issues can suddenly stack up to become a challenging maze of errors. In such a case, things like PHP-version changes can put you in a tight spot and may cause a lot of unneccessary stress. That is why we recomend to regularly update your applications in small increments to avoid the bigger jumps in versions and the potential problems that might come with it.

Backups can be created free of charge via our Control Panel to restore it in case of emergency.

Deactivation of PHP 5.6 and 7.0

The extended support of PHP 5.6 and 7.0 has expired. In the following table you can see when these PHP versions were disabled on which server. You can see on which physical server your account is located in the Control Panel under "Server Overview".

Deactivation DateServernameDeactivated
08.05.2019s2.server.hostpoint.chYes
08.05.2019s3.server.hostpoint.chYes
09.05.2019s4.server.hostpoint.chYes
14.05.2019s6.server.hostpoint.chYes
14.05.2019s7.server.hostpoint.chYes
14.05.2019p1.server.hostpoint.chYes
15.05.2019s8.server.hostpoint.chYes
15.05.2019s9.server.hostpoint.chYes
15.05.2019s10.server.hostpoint.chYes
15.05.2019s11.server.hostpoint.chYes
15.05.2019p2.server.hostpoint.chYes
16.05.2019s13.server.hostpoint.chYes
16.05.2019s14.server.hostpoint.chYes
16.05.2019p3.server.hostpoint.chYes
16.05.2019p4.server.hostpoint.chYes
21.05.2019s15.server.hostpoint.chYes
21.05.2019s16.server.hostpoint.chYes
21.05.2019s17.server.hostpoint.chYes
21.05.2019s18.server.hostpoint.chYes
21.05.2019p5.server.hostpoint.chYes
22.05.2019p6.server.hostpoint.chYes
22.05.2019p7.server.hostpoint.chYes
22.05.2019p8.server.hostpoint.chYes
22.05.2019p9.server.hostpoint.chYes
22.05.2019p10.server.hostpoint.chYes
22.05.2019p11.server.hostpoint.chYes
22.05.2019p12.server.hostpoint.chYes
23.05.2019s20.server.hostpoint.chYes
23.05.2019s23.server.hostpoint.chYes
23.05.2019p13.server.hostpoint.chYes
23.05.2019p14.server.hostpoint.chYes
23.05.2019p15.server.hostpoint.chYes
23.05.2019p16.server.hostpoint.chYes
28.05.2019s25.server.hostpoint.chYes
28.05.2019s27.server.hostpoint.chYes
28.05.2019s30.server.hostpoint.chYes
28.05.2019s32.server.hostpoint.chYes
28.05.2019s33.server.hostpoint.chYes
28.05.2019s34.server.hostpoint.chYes
04.06.2019s35.server.hostpoint.chYes
04.06.2019s36.server.hostpoint.chYes
04.06.2019s37.server.hostpoint.chYes
05.06.2019s38.server.hostpoint.chYes
05.06.2019s40.server.hostpoint.chYes
05.06.2019s41.server.hostpoint.chYes
06.06.2019s42.server.hostpoint.chYes
06.06.2019s43.server.hostpoint.chYes
11.06.2019s44.server.hostpoint.chYes
11.06.2019s45.server.hostpoint.chYes
11.06.2019s50.server.hostpoint.chYes
11.06.2019s51.server.hostpoint.chYes
12.06.2019s52.server.hostpoint.chYes
12.06.2019s53.server.hostpoint.chYes
12.06.2019s54.server.hostpoint.chYes
13.06.2019s55.server.hostpoint.chYes
13.06.2019s57.server.hostpoint.chYes
18.06.2019s58.server.hostpoint.chYes
18.06.2019s61.server.hostpoint.chYes
19.06.2019s62.server.hostpoint.chYes
19.06.2019s63.server.hostpoint.chYes
20.06.2019s68.server.hostpoint.chYes
20.06.2019s69.server.hostpoint.chYes

Information regarding PHP Version change

 

Unable to find what you were looking for?

Our support experts are happy to assist you personally!

 

© 2001 - Hostpoint AG